Tutorial

系统依赖参考 EIM 教程

安装依赖

我的环境是:MacOS blender 2.8

cd /Applications/blender.app/Contents/Resources/2.80/python/bin
wget https://bootstrap.pypa.io/get-pip.py
./python3.7m ./get-pip.py --prefix /Applications/blender.app/Contents/Resources/2.80/python
./python3.7m pip3 install codelab_adapter_client

在 blender 中运行 blender_server

在 blender 中运行 blender_server.py,我们在 blender 2.79 和 2.80 两个版本中都做了测试。

在 blender 2.79b 中, 打开Text Editor,运行 blender_server.py

在 blender 2.80 中,我喜欢打开 Scripting 标签页(使用 Text Editor 也可以),运行 blender_server.py

在 CodeLab Adapter 运行 extension_blender.py 插件

下载https://github.com/CodeLabClub/codelab_adapter_extensions/blob/master/extensions_v2/extension_blender.py插件。

下载完成后,刷新 CodeLab Adapter Web UI,或者手动将其放到插件目录。

开始使用

打开 CodeLab Scratch3,开始使用。

如果遇到问题,请尝试刷新浏览器缓存。

todo

blender_server 写成 blender 插件。